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Exam A

QUESTION 1
Which Illustrator feature allows you to export Illustrator layers to HTML with absolute positioning and with
the ability to overlap each other?

A. Slices
B. Guides
C. Symbols
D. CSS Layers

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 2
What should you do if you are creating graphics that will be used only on the Web?
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A. work in RGB color mode
B. work in CMYK color mode
C. compress continuous-tone images with a broad range of subtle variations in brightness and hue with the

GIF file format
D. use the JPEG file format to maintain high quality, vector images that will be used for creating animation

frames on the Web

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 3
You have created artwork for the Web using your two company colors.

Which format and settings from the Save for Web dialog box should you choose for optimization?

A. JPEG
B. PNG - 8
C. GIF; Web
D. GIF; selective

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:



QUESTION 4
You have created a document that contains your company logo using spot colors and an imported
photograph of your business location. This document will be used on your website home page so flexibility
in choosing image compression is a prerequisite. Which file format should you choose?

A. GIF
B. PNG
C. SVG
D. JPEG

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 5
You are creating an SWF animation and want to reduce the size of your file.

What should you do?

A. use Symbols
B. use Variables
C. choose Object > Blend > Expand
D. choose Object > Blend > Release

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 6
You want to place a high quality resolution independent graphic on your Web page. Which format would
you choose?

A. SVG
B. EPS
C. PNG
D. JPEG

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 7
You are exporting artwork as an Illustrator Legacy file that is compatible with Illustrator 10. You have
selected Embed All Fonts. Which statement is true when using the file on a system that does not have the
original fonts?

A. The original fonts will display when the file is opened in Illustrator.
B. The original fonts will be rasterized when the file is opened in Illustrator.
C. The fonts will substitute when the file is placed in a page layout application.
D. The fonts will display and print properly when the file is placed in a page layout application.



Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 8
You need to produce a document which will be compatible with an older application that only supports the
Adobe Illustrator 8 file format. What should you do?

A. choose File > Save a Copy
B. choose File > Save As, then select Illustrator EPS
C. choose File > Export then select Illustrator Legacy EPS (eps)
D. choose File > Save As, then select Adobe Illustrator Document

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 9
Which is a benefit of exporting a file to Photoshop format (PSD)?

A. Layers may be preserved.
B. You can set the frame rate.
C. HTML code can be generated.
D. You can set image compression.

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 10
Which file format supports partial opacity when exporting an Adobe Illustrator document?
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A. GIF
B. PSD
C. PICT
D. JPEG

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:



QUESTION 11
Which file format allows you to create resolution-independent Web graphics that support JavaScript?

A. GIF
B. SVG
C. BMP
D. JPEG

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 12
You need to export an Adobe Illustrator file to a format that supports lossless compression, the display of
images on the World Wide Web, 24-bit images, and transparent backgrounds. Which format provides
these options?

A. GIF
B. PNG
C. WMF
D. JPEG

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 13
You have applied a Scatter brush to a path. The path is selected. What should you do to change the color
of the brush objects?

A. double click the brush, set the Colorization Method to Tints and then select a fill color
B. double click the brush, set the Colorization Method to None and then select a fill color
C. double click the brush, set the Colorization Method to Tints and then select a stroke color
D. double click the brush, set the Colorization Method to None and then select a stroke color

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 14
Which transparency blend mode multiplies the inverse of the blend and base colors, always resulting in a
lighter color?

A. Multiply
B. Screen
C. Lighten
D. Color Dodge



Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 15
Which action can be used to update a symbol in the Symbols palette?

A. drag the modified symbol on top of the old symbol in the Symbols palette
B. click the Break Link button on the Symbols palette and edit the symbol in the artwork
C. Alt-drag (Windows) or Option-drag (Mac OS) the modified symbol on top of the old symbol in the

Symbols palette
D. Ctrl-drag (Windows) or Command-drag (Mac OS) the modified symbol on top of the old symbol in the

Symbols palette

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 16
Click the Exhibit button.

You want to rotate the object by exactly 17 degrees around a specific reference point (marked by X in the
exhibit.)

What should you do?

A. double-click the rotate tool and enter an angle of 17
B. select the rotate tool, click where you want the reference point to be and use the Transform palette to

rotate 17 degrees
C. select the rotate tool, double-click where you want the reference point to be, then enter an angle of 17 in

the Rotate dialog box
D. select the rotate tool, hold down Alt (Windows) or Option (Mac OS) and click where you want the

reference point to be, then enter an angle of 17 in the Rotate dialog box

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 17
You use the selection tool to select an object, then switch to the zoom tool to increase the magnification of
the selected object. Which command will temporarily switch you back to the selection tool?



A. Shift
B. Space bar
C. Alt (Windows) or Option (Mac OS)
D. Control (Windows) or Command (Mac OS)

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 18
Click the Exhibit button.

Which would you choose to change Object A to Object B?

A. Effect > Stylize > Scribble
B. Filter > Distort > Pucker & Bloat
C. Filter > Stylize > Round Corners
D. Effect > Distort & Transform > Pucker & Bloat

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 19
What should you do to add a spot color to the Swatches palette?

A. Shift-drag a color to the Swatches palette
B. Option-drag a color to the Swatches palette
C. Ctrl-drag (Windows) or Command-drag (Mac OS) a color to the Swatches palette
D. Ctrl+Shift-drag (Windows) or Command+Shift-drag (Mac OS) a color to the Swatches palette

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 20



You have placed a red object with 30% opacity on top of a blue object with 80% opacity. You use the Add to
Shape Area shape mode in the Pathfinder palette to combine the two objects. What is the resulting object's
color and opacity?

A. red with 30% opacity
B. red with 80% opacity
C. blue with 30% opacity
D. blue with 80% opacity

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 21
You have drawn a star using the star tool. The corners of the star are squared. You want pointed corners,
so you click the Miter Join icon in the Stroke palette, but the corners remain squared. With the object
selected, what should you do to make the star corners pointed?

A. choose Effect > Sharpen
B. choose Effect > Path > Outline Object
C. increase the Miter Limit in the Stroke palette
D. click the Projecting Cap icon in the Stroke palette

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 22
You want to create an object that will stretch artwork evenly along the length of a path. Which tool should
you use?

A. Pen
B. Art Brush
C. Scatter Brush
D. Pattern Brush

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 23
Click the Exhibit button.

Which of the 3D Extrude & Bevel options will change object A to object B?



A. Bevel Extent In
B. Bevel Extent Out
C. Extrude Cap On
D. Extrude Cap Off

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 24
You have imported a photograph, but you need to create an oval image, rather than rectangular. You have
created a path using the ellipse tool for your clipping mask. Which object order should you use to create the
clipping mask?

A. The bottom object must be the photograph on a locked layer.
B. The top selected object must be the photograph on a visible layer.
C. The top selected object must be the ellipse tool path on a visible layer.
D. The top selected object must be the ellipse tool path on a hidden layer.

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 25
Which command should you use to change the color of the Artboard?

A. File > File Info > Advanced
B. File > Document Color Mode
C. File > Document Setup > Artboard
D. File > Document Setup > Transparency

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 26
You have made several modifications to a large Illustrator file and want to find out how many undos are
available with your current system memory and application settings.

Which component of the work area displays this information?



A. Status bar pop-up menu
B. Actions palette pop-up menu
C. Transform palette pop-up menu
D. Document info palette pop-up menu

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 27
You have been asked to print an existing document on paper that is larger than the size specified for the
original document. You scale the artwork, but when you print, it is cropped to the original paper size. Which
two tasks should you do? (Choose two.)

A. resize the Artboard by using the Page tool
B. resize the Artboard by using the Selection tool
C. change the media size to match the size of the paper
D. select Artboard from the Document Setup dialog box and change the units
E. select Artboard from the Document Setup dialog box and change the setting for Size to match the size

of the paper

Correct Answer: CE
Section: (none)
Explanation

Explanation/Reference:

QUESTION 28
What does the Page tool allow you to do?

A. change the size of the page
B. change the size of the artboard
C. define the placement of crop marks
D. adjust the position of the page on the artboard

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 29
You have received text and graphic files that will be imported into an Adobe Illustrator document. The files
were created on Windows and Macintosh platforms. You need to determine if you have the appropriate
fonts on your computer. What should you do?

A. import your text documents, select the text with missing fonts and underline the text
B. choose Window > Type > Open Type and click on the contextual alternatives button
C. import your text documents, select all of the text and change the fill color to an unused color
D. choose File > Document Setup, select Type from the pop-up menu and choose Substituted Fonts under

Highlight.

Correct Answer: D
Section: (none)



Explanation

Explanation/Reference:

QUESTION 30
Click the Exhibit button. Which statement about this Glyphs palette is true?

A. It shows a Type 1 font.
B. It shows a TrueType font.
C. The * character has more than one form.
D. The $ character has more than one form.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 31
How should you convert a single letter in a string of text into an outline?

A. make the letter its own text object, then choose Effect > Rasterize
B. select the letter with the text tool, then choose Type > Create Outlines
C. make the letter its own text object, then choose Type > Create Outlines
D. select the letter with the text tool, choose Effect > Path > Outline Object

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 32
You want to perform a series of transformations on a text box. You also want to edit the transformations at
a later time. Which Illustrator feature or command allows you to do this?

A. Transform palette
B. Free Transform tool
C. Object > Transform > Transform Each
D. Effect > Distort and Transform > Transform

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 33
You have been using paragraph styles in your text. You click in a paragraph and notice that there's a plus
sign next to the style name in the Paragraph Styles palette. What does the plus sign indicate?

A. Additional text exists but is not visible.
B. The text has been converted to outline.
C. A character style has been applied to the text.
D. The text formatting does not match the paragraph style definition.



Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 34
You have used the polygon tool to create a pentagon with a solid black stroke and a red fill. You use the
area type tool to add text inside the polygon. What happens to the stroke and fill of the pentagon after you
add the text?

A. Both the fill and stroke disappear.
B. Both the fill and stroke remain unchanged.
C. The fill disappears and the stroke remains.
D. The stroke disappears and the fill remains.

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 35
You are using a font format which consists of a single font file for all of its outline, metric, and bitmap data.
This single font file works on both a Macintosh and Windows computer. Which font format are you using?

A. Type 1
B. TrueType
C. OpenType
D. Multiple Master

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 36
You have placed a Microsoft Word document in a type container. You want to change all the type to
Helvetica Bold. What is the most efficient way to do this?

A. open the document in Word, change the type there, and save
B. drag and select all the type by using the Type tool; then change the font in the Character palette
C. click the type container by using the Selection tool; then change the font in the Character palette
D. select the type container, and choose Helvetica in the Character palette; then press Ctrl-B (Windows) or

Command-B (Mac OS) to make it bold

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 37
Where would you change the Adobe Single-line Composer to the Adobe Every-line Composer?



A. the Character palette menu
B. the Paragraph palette menu
C. the Character Style palette menu
D. the Paragraph Style palette menu

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 38
You have created an enveloped object with a text object and a path object.

You want to edit the text. What should you do?

A. choose Select > Object > Text Objects
B. choose Object > Envelope Distort > Edit Contents
C. choose Object > Envelope Distort > Expand and then use the Type tool to edit the text
D. use the Direct Selection tool to select the text portion of the enveloped object and then use the Type tool

to edit the text

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 39
Which statement is true about the SVG format feature in Illustrator?

A. SVG format is entirely JavaScript-based.
B. SVG animations can be created via keyframes in the SVG Interactivity palette.
C. SVG effects can be applied that are NOT rasterized until the file is viewed in a browser.
D. Vector graphics can be produced for the Web that do NOT require an additional browser plug-in.

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 40
Which is a native file format in Adobe Illustrator 11?

A. PDF
B. PSD
C. CGM
D. SWF

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:



QUESTION 41
What can you do while viewing the Actions palette in Button mode?

A. edit actions
B. toggle dialog on/off
C. play sets of actions
D. play an action with a single click

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 42
Which type feature allows you to hang punctuation in the margins of a selected paragraph?

A. optical kerning
B. composition engines
C. OpenType font support
D. optical margin alignment

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 43
In which situation should you use Adobe Illustrator instead of Adobe Photoshop?
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A. when you need to edit a scanned image that is too dark
B. when you need to edit a screen capture displaying the user interface of an application
C. when you need to combine a series of images taken with a digital camera using options to mask, edit

color, and add gaussian blurs
D. when you need to create a logo that will need to be resized often in a page layout program and printed

on output devices of different resolutions

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 44
You are designing a logo that needs to look smooth when resized larger or smaller. Which application
should you use?



A. Adobe Illustrator
B. Adobe Photoshop
C. Adobe Streamline
D. Adobe FrameMaker

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 45
You need to design your company logo so that it can be used in your product brochures, letterhead,
website, and as a large four foot by eight foot banner for your trade show booth. Which scenario best fits
your needs?

A. You should create the design in Illustrator so that it can be printed, but you will need to use Adobe
Photoshop to create the logo for your website.

B. You should create your design in Illustrator so that you can output to print, create your banner sized
document, and save your logo in a Web compatible format.

C. You should create the design in Illustrator so that it can be printed and used for your website, but you
will need to use Adobe InDesign for your trade show banner.

D. You should create your design in Photoshop for your website and then import it into Illustrator so that it
can be scaled to a larger size for both outputting to print and creating your trade show banner.

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 46
Which setting in the Color Settings dialog box determines how Adobe Illustrator will handle files that have
no color profile?

A. Working Spaces
B. Color Management Policies
C. Conversion Options > Intent
D. Conversion Options > Engine

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 47
What is color gamut?

A. the numerical system used to describe color
B. a device-independent theoretical color model
C. the total range of colors reproduced by a device
D. a method a used for converting colors from one device to another

Correct Answer: C



Section: (none)
Explanation

Explanation/Reference:

QUESTION 48
In color management settings, which rendering intent compares the source white point to that of the
destination and shifts color accordingly?

A. Perceptual
B. Saturation
C. Relative Colormetric
D. Absolute Colormetric

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 49
When making default color management decisions, with what does a color management policy compare
profiles?

A. the RGB working space
B. the CMYK working space
C. the current working space
D. the rendering intent that is currently selected
E. the color management engine that is currently selected

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 50
Which command simulates how a document appears WITHOUT converting colors to the proof profile
space?

A. enable View > Proof Colors
B. disable View > Proof Colors
C. choose View > Proof Setup and select Preserve Color Numbers
D. choose View > Proof Setup and deselect Preserve Color Numbers

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 51
What is a benefit of layers?

A. They can be saved as separate files.
B. They can be grouped within an image.



C. They can be printed as color separations.
D. They can be printed in different combinations.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 52
You have created a clipping mask, but need to remove one object from the clipping group without deleting
it. What should you do?

A. select the object and choose Edit > Clear
B. on the Layers palette, drag the object out of the clipping group
C. on the Layers palette, drag the object below the clipping path on the same layer
D. on the Layers palette, drag the object above the clipping path on the same layer

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 53
You have several objects with a red stroke. You observe that the bounding box, path, and anchor points for
the selected objects are also red making it difficult to edit the paths.

What should you do?

A. change the fill color
B. change the layer color
C. change the transparency of the objects
D. change the stacking order of the objects

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 54
You have opened a Photoshop (PSD) file in Illustrator 11 using the Convert Photoshop Layers to Objects
option. Which layer features are preserved?

A. text layers
B. clipping groups
C. adjustment layers
D. layers that use a Knockout option

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:



QUESTION 55
Which action switches the view mode for all other layers in the Layers palette?

A. Shift-click the eye icon in the Layers palette
B. Alt-click (Windows) or Option-click (Mac OS) the eye icon in the Layers palette
C. Ctrl-click (Windows) or Command-click (Mac OS) the eye icon in the Layers palette
D. Alt+Ctrl-click (Windows) or Option+Command-click (Mac OS) the eye icon in the Layers palette

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 56
Which statement about clipping masks in Adobe Illustrator is true?

A. A clipping mask retains its fill and stroke.
B. A bitmapped object can be used as a clipping mask.
C. The clipping mask must be underneath the artwork to be clipped, either as a group or on the Layers

palette.
D. When you mask objects on different layers, the selected objects move to the clipping mask's layer in the

Layers palette.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 57
You are creating a flyer to be published in multiple languages. Which method allows you to use one file for
the different language versions?

A. choose Object > Lock > Selection to suppress printing for the text object
B. choose Type > Show Hidden Characters to display the text object for printing
C. use different layers for each language; show or hide the appropriate layers for output
D. choose Edit > Paste in Front to show the appropriate text object in front of the other text objects

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 58
You are exporting an Illustrator document with symbols on multiple layers to Adobe Photoshop. Which
statement is true about the data exported to the Photoshop file format?

A. Illustrator converts the data into a format compatible with Photoshop.
B. Illustrator preserves the appearance of the artwork by rasterizing the data.
C. Illustrator preserves the appearance of the data by merging the layers in the document.
D. Illustrator preserves the appearance of the data by merging the layers in the document or by rasterizing

the data.

Correct Answer: D



Section: (none)
Explanation

Explanation/Reference:

QUESTION 59
You have a document that uses spot colors and process colors. You want to ensure that the spot colors are
converted to process colors for color separation but are maintained as spot colors in the working document.
What should you do?

A. Choose Edit > Color Settings
B. Choose File > Print and select Output
C. Change the color mode for that object on the color palette
D. Change the color from spot to process on the Swatches palette

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 60
Which guideline improves the quality of printing in your blends, gradients, and gradient mesh objects?

A. use darker colors
B. use an appropriate line screen that retains 256 levels of gray
C. use longer blends to allow more space for the color to change
D. use a blend that changes less than 50% between two or more process-color components

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 61
Which setting in the Document Setup dialog box determines the output quality of rasterized artwork when
transparency is flattened?

A. the Output Resolution setting in the Printing & Export menu
B. the Raster/Vector Balance settings in the Transparency menu
C. the Rasterization Resolution setting in the Transparency menu
D. the Gradient Mesh Resolution setting in the Printing & Export menu

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 62
You have applied transparency effects to various objects in your artwork.

Which process takes place when you print?

A. masking



B. cropping
C. grouping
D. flattening

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 63
You want to delete crop marks that were set directly in your artwork using the Object > Crop Area > Make
option. What should you do to delete the crop marks?

A. choose Object > Crop Area > Release
B. select the crop marks with the Selection tool and delete them
C. deselect Trim Marks in the Marks & Bleed options in the Print dialog box
D. select the artwork and choose Clear Appearance from the Appearance palette menu

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 64
Which action allows you to see an approximation of how transparency and blending will appear in color
separated output?

A. choosing View > Pixel Preview
B. choosing View > Overprint Preview
C. selecting Isolate Blending in the Transparency palette
D. selecting Knockout Group in the Transparency palette

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 65
You need to set the resolution and screen frequency for printing your image to a laser printer or
imagesetter. What should be the general relationship between the resolution and the screen frequency to
obtain the highest quality halftone?

A. The image resolution must divide evenly in the screen frequency.
B. The image resolution should be 4 to 6 times the screen frequency.
C. The screen frequency must divide evenly into the image resolution.
D. The image resolution should be 1.5 to 2 times the screen frequency.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:



QUESTION 66
You need to create multiple sets of crop marks in your document. What should you do?

A. choose Filter > Create > Crop Marks
B. choose File > Print and select Marks and Bleed
C. use the pen tool to draw crop marks around selected sets of objects
D. draw a rectangle with no fill or stroke and group it with a selected set of objects and choose File > Print

and select Marks and Bleed

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 67
You want to improve printing gradients, gradient meshes, and color blends to eliminate discrete bands of
color. What should you do?

A. use long blends
B. use lighter colors or make dark blends short
C. use a line screen that retains 16 or fewer levels of gray
D. use a blend that has less than 20% change between two or more process color components

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 68
You have created an Illustrator document that has multiple pages. Which Artboard setting in the Document
Setup dialog box allows you to print a specific range of pages matching the settings in the Print Setup
(Windows) or Page Setup (Mac OS) dialog box?

A. Tile Full Pages
B. Single Full Page
C. Tile Imageable Areas
D. Show Images In Outline

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 69
Which command should you use to find the options for setting typographer's quotes for your document?

A. choose File > Document Setup
B. choose Window > Type > Character
C. choose Window > Type > Character Styles
D. choose Edit > Preferences > Type & Auto Tracing

Correct Answer: A
Section: (none)



Explanation

Explanation/Reference:

QUESTION 70
Click the Exhibit button.

You want to dock a group of palettes (a) to another existing group of palettes (b).

What should you do to go from the Before to the After portion of the exhibit?

A. You drag the title bar of palette group (a) to the tab area of palette group (b) until you see palette group
(b) darken.

B. You drag the title bar of palette group (a) to the bottom of palette group (b) until you see the bottom of
palette group (b) darken.

C. You drag each palette tab separately from palette group (a) to the bottom of palette group (b) until you
see the bottom of palette group (b) darken.

D. You drag the first palette tab from palette group (a) to the bottom of palette group (b) until you see the
bottom of palette group (b) darken. You then drag each remaining palette tab in group (a) to the top of
the first palette you moved.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 71
Which keyboard shortcut hides all palettes except for the toolbox?

A. Tab
B. Shift + Tab
C. Alt + Tab (Windows) or Option + Tab (Mac OS)
D. Control + Tab (Windows) or Command + Tab (Mac OS)

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 72
You have created a new letter sized document. Your general units preference is set to inches. You want to



change the width of your document to 775 points and the height to 550 points. What should you do?

A. choose Object > Crop Area
B. choose File > Document Setup and change the Artboard width to 775 and the Height to 550
C. choose File > Document Setup and change the Artboard width to 775p and the height to 550p
D. choose File > Document Setup and change the Artboard units to points; enter 775 for the width and 550

for the height

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 73
When color managing your documents, it is important to know if there are any missing profiles or
mismatches in the color profiles. Where do you find the settings to activate these warnings?

A. Edit > Assign Profile
B. Edit > Color Settings
C. Window > Document Info
D. File > Document Color Mode

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 74
In color management settings, which rendering intent will preserve the visual relationship in a way that is
perceived as natural to the human eye?

A. Perceptual
B. Saturation
C. Relative Colormetric
D. Absolute Colormetric

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 75
You have not been color managing your documents and have disabled warning dialog boxes wherever
possible. Now you want to color manage your documents. Where will you find the reset to enable the
warning dialog boxes?

A. Edit > Assign Profile
B. Edit > Color Settings
C. File > Document Color Mode
D. Edit > Preferences > General

Correct Answer: D
Section: (none)



Explanation

Explanation/Reference:

QUESTION 76
Which color management feature determines how source colors are translated into the gamut of the
destination color space?

A. color profiles
B. rendering intent
C. color management engine
D. device independent color space

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 77
Which settings in the Color Settings dialog box sets the default color profile for newly created documents?

A. Working Spaces
B. Color Management Policies
C. Conversion Options > Intent
D. Conversion Options > Engine

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 78
Where in the Save for Web dialog box can you choose a modem speed to display the correct estimated
download time at the bottom of each optimized image option?

A. Preview palette menu
B. Optimize palette menu
C. Settings pop-up menu
D. Optimized File Format pop-up menu

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 79
You are saving irregular shaped objects that have transparent areas as JPEG images for the Web. Which
option in the Save for Web dialog box allows you to set the color for transparent areas?

A. Blur
B. Matte
C. Quality



D. ICC Profile

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 80
Which two file formats are supported by Web browsers? (Choose two.)

A. AI
B. GIF
C. EPS
D. TIFF
E. JPEG

Correct Answer: BE
Section: (none)
Explanation

Explanation/Reference:

QUESTION 81
Which file format will allow you to create a Web graphic with a small file size, and that will not lose
resolution as you enlarge it?

A. GIF
B. PNG
C. SVG
D. JPEG

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 82
You want to build an SWF animation with the objects on a layer. Which option in the Layers palette menu
places each object on its own layer?

A. Flatten Artwork
B. Collect in New Layer
C. Release to Layers (Build)
D. Release to Layers (Sequence)

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 83
A group of objects has transparency applied. How do you set the objects to knock out one another?



A. select the group by using a selection tool; select On for the Knockout Group option in the Transparency
palette

B. select the group by using a selection tool; select Off for the Knockout Group option in the Transparency
palette

C. target the group by using the Layers palette; select the Off setting for Knockout Group option in the
Transparency palette

D. target the group by using the Layers palette; select the On setting for Knockout Group option in the
Transparency palette

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 84
Which statement about clipping masks is true?

A. The masking object must be a vector object.
B. The clipping mask may be moved by using the selection tool.
C. A clipping mask retains the original fill and stroke used to create it.
D. A clipping mask is made from the bottom-most object in a multiple selection.

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 85
Click the Exhibit button.

Which tool should you use to transform the polygon shape on the left into the shape displayed on the right
in the exhibit?

A. warp tool
B. pucker tool
C. scallop tool
D. crystallize tool

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 86



You have selected the Fall Leaf brush, but you would like to change the color of a path of leaves. Which
two methods could you use? (Choose two.)

A. choose Filter > Colors > Adjust Colors
B. select the path and change the fill color
C. select the path and change the stroke color
D. select the path and double click on the Fall Leaf scatter brush; change the colorization to Tints
E. select the path and double click on the Fall Leaf scatter brush; change the colorization to Hue Shift

Correct Answer: DE
Section: (none)
Explanation

Explanation/Reference:

QUESTION 87
Click the Exhibit button.

You have placed the selection tool over an object resulting in the selection cursor symbol changing to the
one displayed in the exhibit.

What does this symbol indicate?

A. The selection tool is over a selected object or group.
B. The selection tool is over an unselected object or group.
C. The selection tool is over an anchor point on a selected object.
D. The selection tool is over an anchor point on an unselected object.

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 88
You have applied a shape mode to selected objects. How should you restore the objects to their original
appearance?

A. click Add to Shape Area in the Pathfinder palette
B. click Subtract from Shape Area in the Pathfinder palette
C. choose Expand Compound Shape from the Pathfinder palette menu
D. choose Release Compound Shape from the Pathfinder palette menu

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:



QUESTION 89
Which statement describes modifications resulting from applying a filter or an effect?

A. Filter menu commands change the underlying object instead of just its appearance.
B. Effects menu commands change the underlying object instead of just its appearance.
C. An Effects option applied to an object can only be removed by using the Edit > Undo command.
D. After using an Effect command, you have immediate access to the new or modified anchor points

created by the effect.

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 90
How can you remove a drop shadow applied to a single symbol within a symbol set?

A. select the symbol set and choose Effects > Stylize > Drop Shadow
B. select the sublayer and click on the Reduce to Basic Appearance button on the Appearance palette
C. select the symbol set and click on the Reduce to Basic Appearance button on the Appearance palette
D. select the symbol set and Option-click (Mac OS) or Alt-click (Windows) on the symbol with the symbol

styler tool

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 91
Within the Stroke palette, you have entered a stroke weight in centimeters (cm) for a selected object.
Adobe Illustrator converts the stroke weight to an equal value in points. Which setting allows you to change
the stroke width to units displayed in centimeters?

A. in the Stroke palette menu, choose Centimeters
B. select stroke in the Appearance palette and choose Centimeters from the palette pop-up menu
C. in the Preferences dialog box, choose Centimeters from the Stroke pop-up menu under Units & Display

Performance
D. in the Preferences dialog box, choose Centimeters from the General pop-up menu under Units &

Display Performance

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 92
You have applied an Extrude & Bevel effect to an object. You want to edit the effect. What should you do?

A. choose Effect > 3D > Extrude & Bevel
B. choose Effect > Apply Extrude & Bevel
C. double-click 3D Extrude & Bevel in the Appearance palette
D. double-click the target indicator for the object in the Layers palette



Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 93
You have created a new process color by using the color palette. You want to add that color as a spot color
to the Swatches palette bypassing the New Swatch dialog box. What should you do?

A. select New Swatch from the Swatches palette menu
B. select Duplicate Swatch from the Swatches palette menu
C. Option-click (Mac OS) or Alt-click (Windows) the New Swatch button
D. Command-click (Mac OS) or Ctrl-click (Windows) the New Swatch button

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 94
Click the Exhibit button.

Which tool should be used to create the object shown in the exhibit?

A. star tool
B. twirl tool
C. pucker tool
D. polygon tool

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 95
You are exporting an Adobe Illustrator file to the PNG format. Which setting in the PNG Options dialog box
displays low-resolution versions of the image as the file downloads in a browser, making the download time
seem shorter, but also increasing file size?

A. Interlaced
B. Resolution
C. Anti-Aliased
D. Background



Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 96
When should you output your Illustrator document to the EPS file format?

A. when using an EPSF Riders file
B. when you are finished editing vector graphics
C. when placing artwork with both rasters and vectors into an unknown page layout program
D. when creating a Web animation that requires scalable vector graphics and NO additional browser plug-

ins

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 97
You are exporting a document containing raster images to the SWF file format. You want to compress the
file. Which option or command in the SWF Format Options dialog box specifies the amount of detail in the
exported raster images?

A. Method
B. Resolution
C. JPEG Quality
D. Image Format > Lossless

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 98
Why would you export a file using the Illustrator Legacy file format?

A. to create a file with Web safe colors
B. to preserve the layers in your file when placed in Adobe Photoshop
C. to create a file that is compatible with previous versions of Illustrator
D. to create a file with editable paths when placed in InDesign and PageMaker

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 99
Which Illustrator Legacy Option Version setting allows you to turn off compression?

A. Illustrator 3



B. Illustrator 8
C. Illustrator 9
D. Illustrator 10

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 100
Which file format allows you to create resolution-independent Web graphics that support JavaScript?

A. GIF
B. SVG
C. BMP
D. JPEG

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 101
You are creating an image in Adobe Illustrator that will be displayed on the Web. You need the exported file
to be compact and to be capable of displaying high quality graphics.

You prefer a vector format and a format that is XML-based. Which file format should you use to export your
image?

A. GIF
B. SVG
C. PSD
D. JPEG

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 102
You have entered several lines of text in a paragraph. What should you do to increase the line spacing
within the paragraph?

A. select all of the text with the type tool and set the leading in the Character palette
B. click once on the text with the type tool and set the leading in the Character palette
C. select all of the text with the type tool and set the space after the paragraph in the Paragraph palette
D. select the text object and choose Adobe Every Line Composer from the Options menu on the

Paragraph palette

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:



QUESTION 103
You want to create an envelope for a text object. Before creating the envelope, what should you do to the
path you want to use as the envelope to ensure that it distorts the text object?

A. group it with the text object
B. place it at the top of the stacking order
C. place it at the bottom of the stacking order
D. select Distort Appearance in the Envelope Options dialog

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 104
You want to import a text file into a polygon shaped object. What should you do?

A. select the type tool and click to place an insertion point in the polygon, then choose File > Place
B. select the area type tool and click to place an insertion point in the polygon, then choose File > Place
C. select the type tool, choose File > Place and select the text file to import; when the loaded text icon

appears, click on the polygon
D. select the area type tool, choose File > Place and choose the text file to import; when the loaded text

icon appears, click on the polygon

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 105
Which two palettes can be used to insert a special character when using an OpenType font? (Choose two).

A. Glyphs
B. Character
C. OpenType
D. Paragraph
E. Character Styles

Correct Answer: AC
Section: (none)
Explanation

Explanation/Reference:

QUESTION 106
What requires manually changing type to outlines before using it in order to modify the type?

A. Skew tool
B. Roughen filter
C. Free Distort effect
D. Difference Blending mode



Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 107
You want a mirror image copy of your text object immediately adjacent to your selected text object. What
should you do?

A. You select your text object with the selection tool. Then, you select the free transform tool and drag a
side handle across the object until you see the mirror image of the text object.

B. You select your text object with the rotation tool. Then, you select the free transform tool and drag
outside the bounding box in a circular movement until you see the mirror image of the text object.

C. You select your text object with the selection tool. Then, you select the rotation tool, click to set the axis
point, and drag across the object while holding down your Option (Mac) / Alt (PC) key until you see the
mirror image copy of the text object.

D. You select your text object with the selection tool. Then, you select the reflect tool, click to set the axis
point, and drag across the object while holding down your Option (Mac OS) / Alt (Windows) key until you
see the mirror image copy of the text object.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 108
Which font format can contain more than 65,000 glyphs in a single font file?

A. Type 1
B. Type 3
C. TrueType
D. OpenType

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 109
How do you create text with hanging indentation?

A. apply left-justified tabs
B. select the Hanging Punctuation option
C. apply a positive left indent value and a negative first line indent
D. apply a negative left indent value and a positive first line indent

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 110



You have created a Character style and you want to apply the style to a single word in a line of text. What
should you do?

A. highlight the word by using the type tool and click on the style in the Character Styles palette
B. select the word by using the selection tool and click on the style in the Character Styles palette
C. select the line of text by using the selection tool and click on the style in the Character Styles palette
D. select the word by using the direct selection tool and click on the style in the Character Styles palette

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 111
You have placed an Adobe Photoshop file into Adobe Illustrator using the Convert Photoshop Layers to
Objects option to preserve as much layer structure as possible. Some layers contain artwork created with
features that Illustrator does NOT support. What does Illustrator do with those layers?

A. discards the layers
B. merges all layers of this type into a single layer
C. preserves the layers, but rasterizes all layers in the file
D. preserves the appearance of the artwork by merging and rasterizing the layers

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 112
You have a complex illustration comprised of many overlapping paths. The positioning of the uppermost
paths makes it difficult to select another path below. What should you do to select an appropriate path
below?

A. choose Edit > Select All
B. click on the target icon for the layer
C. expand the layer for the appropriate path and click on the target icon for that path
D. Command-click (Mac OS) or Ctrl-click (Windows) on objects on top of your target object

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 113
How should you create a clipping mask using the Layers palette?

A. select the sublayers using the top object as the mask shape, then select Make Clipping Mask from the
Layers palette menu

B. select the sublayers using the bottom object as the mask shape, then select Make Clipping Mask from
the Layers palette menu

C. select the layer with multiple objects using the top object as the mask shape, then select Make Clipping
Mask from the Layers palette menu

D. select the layer with multiple objects using the bottom object as the mask shape, then select Make
Clipping Mask from the Layers palette menu



Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 114
Which object attributes can be controlled in the Layers palette?

A. making art on the layer non-printing
B. making art on the layer print with less opacity
C. making art on the layer a separate color mode
D. making art on the layer change to a different stroke width

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 115
What are three appearance attributes that can be applied to layers? (Choose three.)

A. Fill
B. Filters
C. Styles
D. Stroke
E. Blends
F. Gradients

Correct Answer: ACD
Section: (none)
Explanation

Explanation/Reference:

QUESTION 116
Which statement about importing and exporting Adobe Photoshop files from Adobe Illustrator is true?
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A. When a Photoshop file is opened in Illustrator all clipping paths are imported.
B. When you export Illustrator files to Photoshop layers they remain vector objects.
C. A Photoshop file can be placed into Illustrator with its layers all available for editing.
D. A Photoshop file with multiple layers can be opened in Illustrator, and have the layers either converted

to objects or flattened.

Correct Answer: D
Section: (none)



Explanation

Explanation/Reference:

QUESTION 117
Which statement about layers in Adobe Illustrator is true?

A. Hidden layers are automatically deleted when you flatten an Illustrator document.
B. You CANNOT flatten artwork into a layer that is locked, or a layer that is a template.
C. When merging layers, items will be merged into the layer or group that you selected first.
D. Layers can only merge with other layers that are on a lower hierarchical level in the Layers palette.

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 118
You are applying a stroke and fill to a clipping mask. Which statement is true?

A. The stroke and fill are drawn above the clipped objects.
B. The stroke and fill are drawn below the clipped objects.
C. The stroke is drawn below the clipped objects; the fill is drawn above the clipped objects.
D. The stroke is drawn above the clipped objects; the fill is drawn below the clipped objects.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 119
When should you assign registration color?

A. when there are printer's marks
B. when guides are used to align objects in a document
C. when an object should print only on the K (black) separation plate
D. when there are printer's marks that are hidden while printing separations

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 120
You want gradients between two spot colors to print correctly. What should you do?

A. convert them to process colors
B. specify different screen angles for each color
C. specify the same screen angles for each color
D. apply the gradient to both colors and use white

Correct Answer: B



Section: (none)
Explanation

Explanation/Reference:

QUESTION 121
You want to set crop marks directly in your artwork and specify a user defined area that is larger than your
artwork but smaller than the artboard. Which command and/or option should you use?

A. Object > Crop Area > Make
B. Filter > Create > Crop Marks
C. Trim Marks in the Marks & Bleed options in the Print dialog box
D. Registration Marks in the Marks & Bleed options in the Print dialog box

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 122
Your artwork contains overlapping objects. In which situation may trapping be unnecessary when producing
color separations?

A. The artwork contains only spot colors.
B. The objects all share a common color.
C. The artwork contains only process colors.
D. The separations are produced from a PDF file.

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 123
What is the location of the default settings that determine the resolution when complex mesh objects are
rasterized?

A. Create Gradient Mesh
B. Transparency Flattener Presets
C. Document Raster Effects Settings
D. Artboard settings in the Document Setup dialog box

Correct Answer: B
Section: (none)
Explanation

Explanation/Reference:

QUESTION 124
Which rasterization setting can reduce the appearance of jagged edges in the rasterized image, but can
reduce the crispness of fine lines and small text?

A. Anti-alias
B. Resolution



C. Background
D. Create Clipping Mask

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 125
You want to flatten all transparency for raster objects when printing.

Which Transparency setting in the Document Setup dialog box should you use?

A. set Raster/Vector Balance to 1
B. set Output Resolution to 72 ppi
C. set Raster/Vector Balance to 100
D. set Rasterization Resolution to 72 ppi

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 126
When setting the rasterization quality for a file in the Document Rasterization Settings dialog box, you set
the background to transparent. By selecting Background Transparent, which setting in this dialog is no
longer necessary?

A. Anti-alias
B. Resolution
C. Color Model
D. Create Clipping Mask

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 127
Which palette allows you to check what areas of your artwork are affected by transparency?

A. Transparency palette
B. Document Info palette
C. Graphic Styles palette
D. Flattener Preview palette

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 128



Which are two major features of Adobe Illustrator? (Choose two.)

A. Multi-page documents can be created.
B. Precise paths can be created with the pen tool.
C. Portions of an imported image can be extracted.
D. Multiple layers can be created to organize artwork.
E. An imported bitmapped image can be converted to a vector image.

Correct Answer: BD
Section: (none)
Explanation

Explanation/Reference:

QUESTION 129
In which situation should you use Adobe Illustrator instead of Adobe Photoshop?

A. when you need to edit individual pixels in a GIF file
B. when you need to slice images created for use on the Web using ImageReady
C. when you need to remove a flaw in an image that was scanned from an old picture
D. when you need to trace a complex drawing that you scanned with the intention of creating a series of

bezier curves that will remain in a vector format

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 130
Which is a benefit of the slicing feature in Illustrator?

A. Artwork can be sliced and divided into any geometric shape with the slice tool.
B. An image map of artwork can be created to be exported into separate files for an HTML table.
C. Artwork can be divided into auto slices with guides and URLs can be assigned to the auto slices.
D. An HTML table of object-based slices, text-based slices, auto slices, and user slices can be created.

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 131
What can you do while viewing the Actions palette in Button mode?

A. edit actions
B. toggle dialog on/off
C. play sets of actions
D. play an action with a single click

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:



QUESTION 132
Which statement is true about files saved in the Illustrator (.ai) file format?

A. They can be opened only in Adobe Acrobat.
B. They can be opened only in Adobe InDesign.
C. They can be opened and edited in Adobe Acrobat.
D. They can be opened and edited in Adobe InDesign.

Correct Answer: C
Section: (none)
Explanation

Explanation/Reference:

QUESTION 133
In which situation should you use Adobe Illustrator instead of Adobe Photoshop?

A. when you need to edit a scanned image that is too dark
B. when you need to edit a screen capture displaying the user interface of an application
C. when you need to combine a series of images taken with a digital camera using options to mask, edit

color, and add gaussian blurs
D. when you need to create a logo that will need to be resized often in a page layout program and printed

on output devices of different resolutions

Correct Answer: D
Section: (none)
Explanation

Explanation/Reference:

QUESTION 134
Which statement is true about the native file format used by Illustrator?

A. Illustrator files support both raster and vector images.
B. ICC profiles can be embedded into all file types exported by Illustrator.
C. SWF (Flash) files can be placed directly into native Illustrator documents.
D. Illustrator files can be opened directly in Adobe Photoshop, while preserving all editable type.

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:

QUESTION 135
Which Illustrator feature allows you to export Illustrator layers to HTML with absolute positioning and with
the ability to overlap each other?

A. Slices
B. Guides
C. Symbols
D. CSS Layers

Correct Answer: D



Section: (none)
Explanation

Explanation/Reference:

QUESTION 136
You are creating an SWF animation and want to reduce the size of your file.

What should you do?

A. use Symbols
B. use Variables
C. choose Object > Blend > Expand
D. choose Object > Blend > Release

Correct Answer: A
Section: (none)
Explanation

Explanation/Reference:
 

 

http://www.gratisexam.com/ 


